trunk APR version requirement

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

trunk APR version requirement

Joe Orton
On trunk the configure script requires APR 1.4 but mod_proxy_balancer
fails to build with APR < 1.5 since it uses apr_escape.h unconditionally
[1].  Thinking of 2.5/2.6 it might make sense to bump up the APR version
requirement to something newer, any opinions?  RHEL 8 and Bionic
(18.04LTS) both have APR 1.6 so that might make a reasonable target for
those wanting to build against distro APR versions.

grep for APR_VERSION_AT_LEAST --

./server/mpm/simple/simple_run.c:#if !APR_VERSION_AT_LEAST(1,4,0)
./server/mpm/event/event.c:#if !APR_VERSION_AT_LEAST(1,4,0)
./server/util_expr_eval.c:#if APR_VERSION_AT_LEAST(1,5,0)
./server/util_expr_eval.c:#if APR_VERSION_AT_LEAST(1,6,0)
./server/util_expr_eval.c:#if APR_VERSION_AT_LEAST(1,6,0)
./server/listen.c:#if APR_VERSION_AT_LEAST(1,7,0)
./server/listen.c:#if APR_VERSION_AT_LEAST(1,7,0)
./server/listen.c:#if !APR_VERSION_AT_LEAST(1,7,0)
./server/vhost.c:#if !APR_VERSION_AT_LEAST(1,7,0)
./server/vhost.c:#if APR_VERSION_AT_LEAST(1,7,0)
./modules/proxy/mod_serf.c:#if !APR_VERSION_AT_LEAST(1,4,0)
./modules/ssl/mod_ssl_ct.c:#if !APR_VERSION_AT_LEAST(1,5,0)
./modules/filters/mod_crypto.c:#if !APR_VERSION_AT_LEAST(2,0,0)
./modules/filters/mod_crypto.c:#if !APR_VERSION_AT_LEAST(2,0,0) && \
./modules/lua/lua_passwd.h:#if !APR_VERSION_AT_LEAST(2,0,0)
./modules/lua/lua_passwd.h:#if APR_VERSION_AT_LEAST(2,0,0) || \
./modules/metadata/mod_remoteip.c:#if !APR_VERSION_AT_LEAST(1,5,0)
./support/passwd_common.h:#if !APR_VERSION_AT_LEAST(2,0,0)
./support/passwd_common.h:#if APR_VERSION_AT_LEAST(2,0,0) || \

Regards, Joe

[1] https://travis-ci.org/notroj/httpd/jobs/609143667

Reply | Threaded
Open this post in threaded view
|

Re: trunk APR version requirement

Stefan Eissing
+1

> Am 08.11.2019 um 10:40 schrieb Joe Orton <[hidden email]>:
>
> On trunk the configure script requires APR 1.4 but mod_proxy_balancer
> fails to build with APR < 1.5 since it uses apr_escape.h unconditionally
> [1].  Thinking of 2.5/2.6 it might make sense to bump up the APR version
> requirement to something newer, any opinions?  RHEL 8 and Bionic
> (18.04LTS) both have APR 1.6 so that might make a reasonable target for
> those wanting to build against distro APR versions.
>
> grep for APR_VERSION_AT_LEAST --
>
> ./server/mpm/simple/simple_run.c:#if !APR_VERSION_AT_LEAST(1,4,0)
> ./server/mpm/event/event.c:#if !APR_VERSION_AT_LEAST(1,4,0)
> ./server/util_expr_eval.c:#if APR_VERSION_AT_LEAST(1,5,0)
> ./server/util_expr_eval.c:#if APR_VERSION_AT_LEAST(1,6,0)
> ./server/util_expr_eval.c:#if APR_VERSION_AT_LEAST(1,6,0)
> ./server/listen.c:#if APR_VERSION_AT_LEAST(1,7,0)
> ./server/listen.c:#if APR_VERSION_AT_LEAST(1,7,0)
> ./server/listen.c:#if !APR_VERSION_AT_LEAST(1,7,0)
> ./server/vhost.c:#if !APR_VERSION_AT_LEAST(1,7,0)
> ./server/vhost.c:#if APR_VERSION_AT_LEAST(1,7,0)
> ./modules/proxy/mod_serf.c:#if !APR_VERSION_AT_LEAST(1,4,0)
> ./modules/ssl/mod_ssl_ct.c:#if !APR_VERSION_AT_LEAST(1,5,0)
> ./modules/filters/mod_crypto.c:#if !APR_VERSION_AT_LEAST(2,0,0)
> ./modules/filters/mod_crypto.c:#if !APR_VERSION_AT_LEAST(2,0,0) && \
> ./modules/lua/lua_passwd.h:#if !APR_VERSION_AT_LEAST(2,0,0)
> ./modules/lua/lua_passwd.h:#if APR_VERSION_AT_LEAST(2,0,0) || \
> ./modules/metadata/mod_remoteip.c:#if !APR_VERSION_AT_LEAST(1,5,0)
> ./support/passwd_common.h:#if !APR_VERSION_AT_LEAST(2,0,0)
> ./support/passwd_common.h:#if APR_VERSION_AT_LEAST(2,0,0) || \
>
> Regards, Joe
>
> [1] https://travis-ci.org/notroj/httpd/jobs/609143667
>

Reply | Threaded
Open this post in threaded view
|

Re: trunk APR version requirement

Ruediger Pluem
+1

Regards

Rüdiger

On 11/08/2019 10:45 AM, Stefan Eissing wrote:

> +1
>
>> Am 08.11.2019 um 10:40 schrieb Joe Orton <[hidden email]>:
>>
>> On trunk the configure script requires APR 1.4 but mod_proxy_balancer
>> fails to build with APR < 1.5 since it uses apr_escape.h unconditionally
>> [1].  Thinking of 2.5/2.6 it might make sense to bump up the APR version
>> requirement to something newer, any opinions?  RHEL 8 and Bionic
>> (18.04LTS) both have APR 1.6 so that might make a reasonable target for
>> those wanting to build against distro APR versions.
>>
>> grep for APR_VERSION_AT_LEAST --
>>
>> ./server/mpm/simple/simple_run.c:#if !APR_VERSION_AT_LEAST(1,4,0)
>> ./server/mpm/event/event.c:#if !APR_VERSION_AT_LEAST(1,4,0)
>> ./server/util_expr_eval.c:#if APR_VERSION_AT_LEAST(1,5,0)
>> ./server/util_expr_eval.c:#if APR_VERSION_AT_LEAST(1,6,0)
>> ./server/util_expr_eval.c:#if APR_VERSION_AT_LEAST(1,6,0)
>> ./server/listen.c:#if APR_VERSION_AT_LEAST(1,7,0)
>> ./server/listen.c:#if APR_VERSION_AT_LEAST(1,7,0)
>> ./server/listen.c:#if !APR_VERSION_AT_LEAST(1,7,0)
>> ./server/vhost.c:#if !APR_VERSION_AT_LEAST(1,7,0)
>> ./server/vhost.c:#if APR_VERSION_AT_LEAST(1,7,0)
>> ./modules/proxy/mod_serf.c:#if !APR_VERSION_AT_LEAST(1,4,0)
>> ./modules/ssl/mod_ssl_ct.c:#if !APR_VERSION_AT_LEAST(1,5,0)
>> ./modules/filters/mod_crypto.c:#if !APR_VERSION_AT_LEAST(2,0,0)
>> ./modules/filters/mod_crypto.c:#if !APR_VERSION_AT_LEAST(2,0,0) && \
>> ./modules/lua/lua_passwd.h:#if !APR_VERSION_AT_LEAST(2,0,0)
>> ./modules/lua/lua_passwd.h:#if APR_VERSION_AT_LEAST(2,0,0) || \
>> ./modules/metadata/mod_remoteip.c:#if !APR_VERSION_AT_LEAST(1,5,0)
>> ./support/passwd_common.h:#if !APR_VERSION_AT_LEAST(2,0,0)
>> ./support/passwd_common.h:#if APR_VERSION_AT_LEAST(2,0,0) || \
>>
>> Regards, Joe
>>
>> [1] https://travis-ci.org/notroj/httpd/jobs/609143667
>>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: trunk APR version requirement

Mario Brandt-2
In reply to this post by Joe Orton
+1

Joe Orton <[hidden email]> schrieb am Fr., 8. Nov. 2019, 10:40:
On trunk the configure script requires APR 1.4 but mod_proxy_balancer
fails to build with APR < 1.5 since it uses apr_escape.h unconditionally
[1].  Thinking of 2.5/2.6 it might make sense to bump up the APR version
requirement to something newer, any opinions?  RHEL 8 and Bionic
(18.04LTS) both have APR 1.6 so that might make a reasonable target for
those wanting to build against distro APR versions.

grep for APR_VERSION_AT_LEAST --

./server/mpm/simple/simple_run.c:#if !APR_VERSION_AT_LEAST(1,4,0)
./server/mpm/event/event.c:#if !APR_VERSION_AT_LEAST(1,4,0)
./server/util_expr_eval.c:#if APR_VERSION_AT_LEAST(1,5,0)
./server/util_expr_eval.c:#if APR_VERSION_AT_LEAST(1,6,0)
./server/util_expr_eval.c:#if APR_VERSION_AT_LEAST(1,6,0)
./server/listen.c:#if APR_VERSION_AT_LEAST(1,7,0)
./server/listen.c:#if APR_VERSION_AT_LEAST(1,7,0)
./server/listen.c:#if !APR_VERSION_AT_LEAST(1,7,0)
./server/vhost.c:#if !APR_VERSION_AT_LEAST(1,7,0)
./server/vhost.c:#if APR_VERSION_AT_LEAST(1,7,0)
./modules/proxy/mod_serf.c:#if !APR_VERSION_AT_LEAST(1,4,0)
./modules/ssl/mod_ssl_ct.c:#if !APR_VERSION_AT_LEAST(1,5,0)
./modules/filters/mod_crypto.c:#if !APR_VERSION_AT_LEAST(2,0,0)
./modules/filters/mod_crypto.c:#if !APR_VERSION_AT_LEAST(2,0,0) && \
./modules/lua/lua_passwd.h:#if !APR_VERSION_AT_LEAST(2,0,0)
./modules/lua/lua_passwd.h:#if APR_VERSION_AT_LEAST(2,0,0) || \
./modules/metadata/mod_remoteip.c:#if !APR_VERSION_AT_LEAST(1,5,0)
./support/passwd_common.h:#if !APR_VERSION_AT_LEAST(2,0,0)
./support/passwd_common.h:#if APR_VERSION_AT_LEAST(2,0,0) || \

Regards, Joe

[1] https://travis-ci.org/notroj/httpd/jobs/609143667

Reply | Threaded
Open this post in threaded view
|

Re: trunk APR version requirement

Graham Leggett
In reply to this post by Joe Orton
On 08 Nov 2019, at 11:40, Joe Orton <[hidden email]> wrote:

> On trunk the configure script requires APR 1.4 but mod_proxy_balancer
> fails to build with APR < 1.5 since it uses apr_escape.h unconditionally
> [1].  Thinking of 2.5/2.6 it might make sense to bump up the APR version
> requirement to something newer, any opinions?  RHEL 8 and Bionic
> (18.04LTS) both have APR 1.6 so that might make a reasonable target for
> those wanting to build against distro APR versions.

I’m keen for apr(-util) v1.7, because there is JSON and JOSE (AKA JWT) support that I want to take advantage of on the 2.5/2.6 series.

Given that 1.6 is in current long term support OSes as described above, I’m also happy for apr(-util) 1.6 with the option to use v1.7 where required.

Regards,
Graham



smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: trunk APR version requirement

Joe Orton
In reply to this post by Ruediger Pluem
Thanks to everyone who gave feedback, I made the change to require APR
1.6 in r1869684.  While I kept the Travis builds passing, buildbot broke
since it's doing a trunk build against the system APR.  Does anybody
know if there is a buildbot slave running Bionic?

Regards, Joe

Reply | Threaded
Open this post in threaded view
|

Re: trunk APR version requirement

Luca Toscano
Il giorno mar 12 nov 2019 alle ore 12:40 Joe Orton <[hidden email]>
ha scritto:
>
> Thanks to everyone who gave feedback, I made the change to require APR
> 1.6 in r1869684.  While I kept the Travis builds passing, buildbot broke
> since it's doing a trunk build against the system APR.  Does anybody
> know if there is a buildbot slave running Bionic?

Or maybe we could think about swapping buildbot with Travis and set
notifications for the latter to dev@. Travis seems working really well
and after all your recent work IIUC it is already testing way more
than what buildbot does :)

Luca
Reply | Threaded
Open this post in threaded view
|

Re: trunk APR version requirement

Joe Orton
On Tue, Nov 12, 2019 at 02:39:58PM +0100, Luca Toscano wrote:

> Il giorno mar 12 nov 2019 alle ore 12:40 Joe Orton <[hidden email]>
> ha scritto:
> >
> > Thanks to everyone who gave feedback, I made the change to require APR
> > 1.6 in r1869684.  While I kept the Travis builds passing, buildbot broke
> > since it's doing a trunk build against the system APR.  Does anybody
> > know if there is a buildbot slave running Bionic?
>
> Or maybe we could think about swapping buildbot with Travis and set
> notifications for the latter to dev@. Travis seems working really well
> and after all your recent work IIUC it is already testing way more
> than what buildbot does :)

I'm fine with disabling bb if nobody wants to rescue it - and I didn't
deliberately sabotage it!  We need to keep the doxygen bb stuff running,
that has failed to build as well though I think it's only a
non-reproducible failure, because an existing checkout has been
reconfigured using the included APR (trunk) and still has objects built
against APR 1.x.

How about:

1. If travis results look stable this week, turn on e-mail notifications
to dev@ on Friday.

2. Friday following (22nd), disable the broken bits of buildbot if
nobody has salvaged it.

Regards, Joe



Reply | Threaded
Open this post in threaded view
|

Re: trunk APR version requirement

Eric Covener
>
> 1. If travis results look stable this week, turn on e-mail notifications
> to dev@ on Friday.
>
> 2. Friday following (22nd), disable the broken bits of buildbot if
> nobody has salvaged it.

+1
Reply | Threaded
Open this post in threaded view
|

Re: trunk APR version requirement

Luca Toscano
Il giorno mar 12 nov 2019 alle ore 15:24 Eric Covener
<[hidden email]> ha scritto:
>
> >
> > 1. If travis results look stable this week, turn on e-mail notifications
> > to dev@ on Friday.
> >
> > 2. Friday following (22nd), disable the broken bits of buildbot if
> > nobody has salvaged it.
>
> +1

+1
Reply | Threaded
Open this post in threaded view
|

Re: trunk APR version requirement

Yann Ylavic
On Tue, Nov 12, 2019 at 3:43 PM Luca Toscano <[hidden email]> wrote:

>
> Il giorno mar 12 nov 2019 alle ore 15:24 Eric Covener
> <[hidden email]> ha scritto:
> >
> > >
> > > 1. If travis results look stable this week, turn on e-mail notifications
> > > to dev@ on Friday.
> > >
> > > 2. Friday following (22nd), disable the broken bits of buildbot if
> > > nobody has salvaged it.
> >
> > +1
>
> +1

+1 (and great job Jo & Luca!)
Reply | Threaded
Open this post in threaded view
|

Re: trunk APR version requirement

Stefan Eissing
Very happy about this. Thanks a lot!

> Am 12.11.2019 um 16:10 schrieb Yann Ylavic <[hidden email]>:
>
> On Tue, Nov 12, 2019 at 3:43 PM Luca Toscano <[hidden email]> wrote:
>>
>> Il giorno mar 12 nov 2019 alle ore 15:24 Eric Covener
>> <[hidden email]> ha scritto:
>>>
>>>>
>>>> 1. If travis results look stable this week, turn on e-mail notifications
>>>> to dev@ on Friday.
>>>>
>>>> 2. Friday following (22nd), disable the broken bits of buildbot if
>>>> nobody has salvaged it.
>>>
>>> +1
>>
>> +1
>
> +1 (and great job Jo & Luca!)

Reply | Threaded
Open this post in threaded view
|

Re: trunk APR version requirement

Ruediger Pluem
Great work. Thanks Joe and Luca.

Regards

Rüdiger

On 11/12/2019 04:14 PM, Stefan Eissing wrote:

> Very happy about this. Thanks a lot!
>
>> Am 12.11.2019 um 16:10 schrieb Yann Ylavic <[hidden email]>:
>>
>> On Tue, Nov 12, 2019 at 3:43 PM Luca Toscano <[hidden email]> wrote:
>>>
>>> Il giorno mar 12 nov 2019 alle ore 15:24 Eric Covener
>>> <[hidden email]> ha scritto:
>>>>
>>>>>
>>>>> 1. If travis results look stable this week, turn on e-mail notifications
>>>>> to dev@ on Friday.
>>>>>
>>>>> 2. Friday following (22nd), disable the broken bits of buildbot if
>>>>> nobody has salvaged it.
>>>>
>>>> +1
>>>
>>> +1
>>
>> +1 (and great job Jo & Luca!)
>
>