Temp files sometimes not deleted (/tmp/modproxy.tmp.*)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Temp files sometimes not deleted (/tmp/modproxy.tmp.*)

simon.studer
Hi everyone,

With the Upgrade to Apache httpd version 2.4.43, a new problem has come up: The temp files /tmp/modproxy.tmp.* are frequently not deleted. This, over time, fills the disk.

The problem disappears if we downgrade to the version we had in use before that (which was 2.4.41).

We are seeing this behavior on all systems, where version 2.4.43 is in use but we are unable to reproduce it in a container as of yet. Also, we could not find any errors, that could point to the source of this (not even at higher log levels).

Between 2.4.41 and 2.4.43, there were various changes to proxy modules: https://github.com/apache/httpd/blob/2.4.x/CHANGES.

It does appear that the connection cleanup has changed, though I am not sure this change is related to the problem:
* https://github.com/apache/httpd/commit/f7d35dc166732bff0e55d1509202d76d53f8c270#diff-037f73ad4a026d77ac9c31a007388308L460

We use a self-compiled Apache httpd:
- apr-1.7.0
- apr-util-1.6.1
- httpd-2.4.43

Any help or suggestions are appreciated.

Thank you!
Simon

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Temp files sometimes not deleted (/tmp/modproxy.tmp.*)

Eric Covener
On Tue, Jun 2, 2020 at 8:39 AM <[hidden email]> wrote:

>
> Hi everyone,
>
> With the Upgrade to Apache httpd version 2.4.43, a new problem has come up: The temp files /tmp/modproxy.tmp.* are frequently not deleted. This, over time, fills the disk.
>
> The problem disappears if we downgrade to the version we had in use before that (which was 2.4.41).
>
> We are seeing this behavior on all systems, where version 2.4.43 is in use but we are unable to reproduce it in a container as of yet. Also, we could not find any errors, that could point to the source of this (not even at higher log levels).
>
> Between 2.4.41 and 2.4.43, there were various changes to proxy modules: https://github.com/apache/httpd/blob/2.4.x/CHANGES.
>
> It does appear that the connection cleanup has changed, though I am not sure this change is related to the problem:
> * https://github.com/apache/httpd/commit/f7d35dc166732bff0e55d1509202d76d53f8c270#diff-037f73ad4a026d77ac9c31a007388308L460
>
> We use a self-compiled Apache httpd:
> - apr-1.7.0
> - apr-util-1.6.1
> - httpd-2.4.43
>

Will be fixed in the next release, you can pull the fix below:

https://bz.apache.org/bugzilla/show_bug.cgi?id=64452

https://svn.apache.org/viewvc?view=revision&revision=1878280

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

AW: [users@httpd] Temp files sometimes not deleted (/tmp/modproxy.tmp.*)

simon.studer
Hi Eric,

We could not find any bug reports when the issue first came up. I guess I should have checked again before writing to the mailinglist :-)

In any case, thank you for pointing out the bug report!
Simon


-----Urspr√ľngliche Nachricht-----
Von: Eric Covener <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 14:45
An: [hidden email]
Betreff: Re: [users@httpd] Temp files sometimes not deleted (/tmp/modproxy.tmp.*)

On Tue, Jun 2, 2020 at 8:39 AM <[hidden email]> wrote:

>
> Hi everyone,
>
> With the Upgrade to Apache httpd version 2.4.43, a new problem has come up: The temp files /tmp/modproxy.tmp.* are frequently not deleted. This, over time, fills the disk.
>
> The problem disappears if we downgrade to the version we had in use before that (which was 2.4.41).
>
> We are seeing this behavior on all systems, where version 2.4.43 is in use but we are unable to reproduce it in a container as of yet. Also, we could not find any errors, that could point to the source of this (not even at higher log levels).
>
> Between 2.4.41 and 2.4.43, there were various changes to proxy modules: https://github.com/apache/httpd/blob/2.4.x/CHANGES.
>
> It does appear that the connection cleanup has changed, though I am not sure this change is related to the problem:
> * https://github.com/apache/httpd/commit/f7d35dc166732bff0e55d1509202d76d53f8c270#diff-037f73ad4a026d77ac9c31a007388308L460
>
> We use a self-compiled Apache httpd:
> - apr-1.7.0
> - apr-util-1.6.1
> - httpd-2.4.43
>

Will be fixed in the next release, you can pull the fix below:

https://bz.apache.org/bugzilla/show_bug.cgi?id=64452

https://svn.apache.org/viewvc?view=revision&revision=1878280

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]