[Bug 64754] New: balance-manager app produces malformed HTML -- missing </tr>

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 64754] New: balance-manager app produces malformed HTML -- missing </tr>

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=64754

            Bug ID: 64754
           Summary: balance-manager app produces malformed HTML -- missing
                    </tr>
           Product: Apache httpd-2
           Version: 2.5-HEAD
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: minor
          Priority: P2
         Component: mod_proxy_balancer
          Assignee: [hidden email]
          Reporter: [hidden email]
  Target Milestone: ---

The balance-manager internal application is missing a "</tr>" before a
"</table>" around line 1650. Trunk currently has

            ap_rprintf(r, "<td>%s</td>\n",
                       !balancer->s->inactive ? "Yes" : "No");
            ap_rputs("</table>\n<br />", r);

I'd suggest adding the "</tr>" either like this:

            ap_rprintf(r, "<td>%s</td>\n",
                       !balancer->s->inactive ? "Yes" : "No");
            ap_rputs("</tr>\n</table>\n<br />", r);

or like this:

            ap_rprintf(r, "<td>%s</td>\n</tr>\n",
                       !balancer->s->inactive ? "Yes" : "No");
            ap_rputs("</table>\n<br />", r);

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 64754] balance-manager app produces malformed HTML -- missing </tr>

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=64754

Christophe JAILLET <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         Resolution|---                         |FIXED
             Status|NEW                         |RESOLVED

--- Comment #1 from Christophe JAILLET <[hidden email]> ---
Hi,

thanks for spotting it.
This has been fixed in trunk in r1882210.

This will be proposed for backport in 2.4.x in a near future.

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]