[Bug 64699] New: Ab cannot support TLSv1.3

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 64699] New: Ab cannot support TLSv1.3

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=64699

            Bug ID: 64699
           Summary: Ab cannot support TLSv1.3
           Product: Apache httpd-2
           Version: 2.5-HEAD
          Hardware: PC
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_http2
          Assignee: [hidden email]
          Reporter: [hidden email]
  Target Milestone: ---

Ab cannot support TLSv1.3.

TLSv1.3 is becoming more and more widely used, but AB is not currently
supported. Can you support it?

I made a small patch in httpd-2.4.46 to implement this function. Could you
please help me review and add this function.

See the attachment´╝Ü
0001-support-TLS1.3.patch
Thank you!

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 64699] Ab cannot support TLSv1.3

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=64699

jiangxiaolong <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Version|2.5-HEAD                    |2.4.46
                 OS|                            |All

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 64699] Ab cannot support TLSv1.3

Bugzilla from bugzilla@apache.org
In reply to this post by Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=64699

Christophe JAILLET <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |NEEDINFO

--- Comment #1 from Christophe JAILLET <[hidden email]> ---
Hi jiangxiaolong,

no file has been attached so far to your report.

We are always pleased to receive new contribution (and new contributors). So
don't hesitate to come back to us.

Regards,
CJ

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 64699] Ab cannot support TLSv1.3

Bugzilla from bugzilla@apache.org
In reply to this post by Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=64699

--- Comment #3 from jiangxiaolong <[hidden email]> ---
Created attachment 37414
  --> https://bz.apache.org/bugzilla/attachment.cgi?id=37414&action=edit
add support TLSv1.3 for ab

httpd-2.4.46, add support TLSv1.3 for ab.

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]