[Bug 63893] New: Bogus warning "unsupported command 20"

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 63893] New: Bogus warning "unsupported command 20"

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=63893

            Bug ID: 63893
           Summary: Bogus warning "unsupported command 20"
           Product: Apache httpd-2
           Version: 2.4.38
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_remoteip
          Assignee: [hidden email]
          Reporter: [hidden email]
  Target Milestone: ---

My log filled just my complete EC2 HDD because apache remoteip spams my logs
full with "RemoteIPProxyProtocol: unsupported command 20". This is caused by
the health checks of AWS's NLB - which sends LOCAL ver_cmd proxy headers to
check for problems.

This is (according to the spec
https://www.haproxy.org/download/1.8/doc/proxy-protocol.txt) a valid ver_cmd
and shouldn't cause these kind of log spam.

See "9. Sample code" for details.

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 63893] Bogus warning "unsupported command 20"

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=63893

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]