[Bug 63466] New: unable to use hctemplate

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 63466] New: unable to use hctemplate

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=63466

            Bug ID: 63466
           Summary: unable to use hctemplate
           Product: Apache httpd-2
           Version: 2.4.29
          Hardware: HP
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_proxy_hcheck
          Assignee: [hidden email]
          Reporter: [hidden email]
  Target Milestone: ---

Hi, I try to start a httpd with an

ProxyHCTemplate esb hcmethod=GET hcpasses=1 hcfails=1 hcinterval=30
hcuri=/esb/healthcheck

in the httpd.conf and a blancer config in an VirtualHost section with

<Proxy balancer://services>
   BalancerMember ajp://server1:8009 hctemplate=esb
   BalancerMember ajp://server2:8009 hctemplate=esb
</Proxy>

The start of the vhost stops with a

28000 Segmentation fault      (core dumped) $HTTPD -k $cmd -D$server

Without using an template (configuring the balancer like this:)

<Proxy balancer://services>
   BalancerMember http://server1:8080 hcmethod=GET hcpasses=1 hcfails=1
hcinterval=30 hcuri=/esb/healthcheck
   BalancerMember http://server2:8080 hcmethod=GET hcpasses=1 hcfails=1
hcinterval=30 hcuri=/esb/healthcheck
</Proxy>

it works fine.

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 63466] unable to use hctemplate

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=63466

--- Comment #1 from Christophe JAILLET <[hidden email]> ---
Hi,

I can not reproduce with 2.4.39.
Can you test with a newer version than 2.4.29?


I don't know if it is a typo but the first BalancerMember are with ajp://, and
the 2nd example is with http://

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 63466] unable to use hctemplate

Bugzilla from bugzilla@apache.org
In reply to this post by Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=63466

--- Comment #2 from Jörg Schünemann <[hidden email]> ---
(In reply to Christophe JAILLET from comment #1)
> Hi,
>
> I can not reproduce with 2.4.39.
> Can you test with a newer version than 2.4.29?
>
>
> I don't know if it is a typo but the first BalancerMember are with ajp://,
> and the 2nd example is with http://

Hi Christophe.

It it just a typo I tried both versions (ajp and http). I will test the config
with a newer version and report the result .

Kind regards
Jörg

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]