[Bug 61876] New: OCSP response status logged incorrectly

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 61876] New: OCSP response status logged incorrectly

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=61876

            Bug ID: 61876
           Summary: OCSP response status logged incorrectly
           Product: Apache httpd-2
           Version: 2.4.27
          Hardware: PC
                OS: Mac OS X 10.1
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_ssl
          Assignee: [hidden email]
          Reporter: [hidden email]
  Target Milestone: ---

In verify_ocsp_status in ssl_engine_ocsp.c, the log message, "OCSP response not
successful: %d" should print the value of r instead of rc. The value of rc will
always be 0.

157    if (rc == V_OCSP_CERTSTATUS_GOOD) {
158        int r = OCSP_response_status(response);
159
160        if (r != OCSP_RESPONSE_STATUS_SUCCESSFUL) {
161            ap_log_error(APLOG_MARK, APLOG_ERR, 0, s, APLOGNO(01922)
162                         "OCSP response not successful: %d", rc);
163            rc = V_OCSP_CERTSTATUS_UNKNOWN;
164        }
165    }

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 61876] OCSP response status logged incorrectly

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=61876

--- Comment #1 from Christophe JAILLET <[hidden email]> ---
Thanks for the report.

Fixed in trunk in r1817598.

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 61876] OCSP response status logged incorrectly

Bugzilla from bugzilla@apache.org
In reply to this post by Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=61876

Christophe JAILLET <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         Resolution|---                         |FIXED
             Status|NEW                         |RESOLVED

--- Comment #2 from Christophe JAILLET <[hidden email]> ---
backported in 2.4.x in r1832607

This is part of 2.4.34

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]