Apache 2.4.25 with openssl 1.1.0e

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Apache 2.4.25 with openssl 1.1.0e

Hemant Chaudhary
Hi

I am trying to build httpd-2.4.25 with openssl-1.1.0e. But getting error in SSLv2_Client_Method, CRYPTO_malloc_init functions . 

Whether anyone encountered the same problem?
Does apache-2.4.25 support openssl 1.1.0e?

Thanks
Hemant
Reply | Threaded
Open this post in threaded view
|

Re: Apache 2.4.25 with openssl 1.1.0e

Luca Toscano
Hi,

2017-06-05 8:52 GMT+02:00 Hemant Chaudhary <[hidden email]>:
Hi

I am trying to build httpd-2.4.25 with openssl-1.1.0e. But getting error in SSLv2_Client_Method, CRYPTO_malloc_init functions . 

Whether anyone encountered the same problem?
Does apache-2.4.25 support openssl 1.1.0e?

The support has been added only recently, so 2.4.25 does not support it. You can try to apply the following patch though:

svn.apache.org/r1787728 (commit msg is a bit misleading, probably related to another change)

Luca