Apache 2.0.53 SSL

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Apache 2.0.53 SSL

Farid Izem
Hi all,

Using Apache 2.0.53 on Solaris 8. I have compile my apache without problem and
When i try to start it using a good configuration, i 'm facing the
following problem :

Syntax error on line 256 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/modules/mod_ssl.so into server: ld.so.1:
/usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/apache/modules/mod_ssl.so: symbol X509_INFO_free:
referenced symbol not found

How do i solve this ?

I found the following answer :

You may need to Create Runtime Link Environment (crle) for SSL by doing this -
crle -c /var/ld/ld.config -l /usr/local/openssl/lib:/usr/lib:/usr/local/lib:

But it doesn't change anything.

Any help would be much appreciate !

King Regards,

Farid

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: [hidden email]
   "   from the digest: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Apache 2.0.53 SSL

Joost de Heer
Farid Izem said:

> Hi all,
>
> Using Apache 2.0.53 on Solaris 8. I have compile my apache without problem
> and
> When i try to start it using a good configuration, i 'm facing the
> following problem :
>
> Syntax error on line 256 of /usr/local/apache/conf/httpd.conf:
> Cannot load /usr/local/apache/modules/mod_ssl.so into server: ld.so.1:
> /usr/local/apache/bin/httpd: fatal: relocation error: file
> /usr/local/apache/modules/mod_ssl.so: symbol X509_INFO_free:
> referenced symbol not found

Are the SSL libraries in your LD_LIBRARY_PATH? If you installed them from
Sunfreeware.com, the path is, I think, /usr/local/ssl/lib, and this
usually isn't in the default libpath.

You could add the following lines to apachectl at the top to fix this:

LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/usr/local/ssl/lib
export LD_LIBRARY_PATH

Joost


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: [hidden email]
   "   from the digest: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Re: Apache 2.0.53 SSL

Jirka Vejrazka
> > Using Apache 2.0.53 on Solaris 8. I have compile my apache without problem
> > and
> > When i try to start it using a good configuration, i 'm facing the
> > following problem :
> >
> > Syntax error on line 256 of /usr/local/apache/conf/httpd.conf:
> > Cannot load /usr/local/apache/modules/mod_ssl.so into server: ld.so.1:
> > /usr/local/apache/bin/httpd: fatal: relocation error: file
> > /usr/local/apache/modules/mod_ssl.so: symbol X509_INFO_free:
> > referenced symbol not found

Have you checked Google? If you had, you'd find my answer to this question here:
http://www.issociate.de/board/post/45069/errors_starting_apache2.0.45__with_mod_ssl_as_DSO..html

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: [hidden email]
   "   from the digest: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Re: Apache 2.0.53 SSL

Farid Izem
Hi all,

After thinking on my problem, i remember i haven't put env directive
specifying LDFlags
To Openssl librairies.

The compile line should have been : (LDAP / Openssl Support).

env "CPPFLAGS=-I/usr/local/openldap/include
-I/usr/local/openssl/include" "LDFLAGS=-L/usr/local/openldap/lib
-L/usr/local/openssl/lib" ./configure --prefix=/usr/local/apache
--enable-mods-shared=all --enable-ssl --with-ldap --enable-ldap
--enable-auth-ldap --enable-proxy --enable-proxy-connect
--enable-proxy-http --enable-proxy-ftp

Now it works.

Kind Regards,

Farid.

On 4/26/05, Jirka Vejrazka <[hidden email]> wrote:

> > > Using Apache 2.0.53 on Solaris 8. I have compile my apache without problem
> > > and
> > > When i try to start it using a good configuration, i 'm facing the
> > > following problem :
> > >
> > > Syntax error on line 256 of /usr/local/apache/conf/httpd.conf:
> > > Cannot load /usr/local/apache/modules/mod_ssl.so into server: ld.so.1:
> > > /usr/local/apache/bin/httpd: fatal: relocation error: file
> > > /usr/local/apache/modules/mod_ssl.so: symbol X509_INFO_free:
> > > referenced symbol not found
>
> Have you checked Google? If you had, you'd find my answer to this question here:
> http://www.issociate.de/board/post/45069/errors_starting_apache2.0.45__with_mod_ssl_as_DSO..html
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: [hidden email]
>    "   from the digest: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: [hidden email]
   "   from the digest: [hidden email]
For additional commands, e-mail: [hidden email]